読者です 読者をやめる 読者になる 読者になる

とっしぃのTech Memo

PHPとかサーバとか他色々言語のメモ的な。あとはたまにガジェットとか。

VimのNeobundleで「neobundle#rc() is deprecated function.」

お久しぶりです。とっしぃです。

最近家庭の事情もありましてなかなか記事が書けてないです(´・ω・`)


でとりあえず軽いテーマが一つあったのでちょろっと更新。



普段使ってるエディタは基本的にVimなんですが、最近部署が変わったこともあって新しいMacBookProが支給されたのでそれにもVimの設定しとこうと思ったわけです。

そしたら

[neobundle] neobundle#rc() is deprecated function.
[neobundle] It will be removed in the next version.
[neobundle] Please use neobundle#begin()/neobundle#end() instead.

なんだこれ(´・ω・`)


上のメッセージをよく読んでみると、


neobundle#rcは次のバージョンでなくなるから、neobundle#begin()/neobundle#end() 使ってね


と。


調べてみるとまぁちょこちょこ出てきますね。

ここ(
neobundle#rc()がdeprecated functionになる場合 - Qiita
)を参考に

call neobundle#begin(expand('~/.vim/bundle/'))
NeoBundleFetch 'Shougo/neobundle.vim'
call neobundle#end()

これで出なくなりました。やったね!


他の参考:

Shougo/neobundle.vim · GitHub

VimでNeoBundleのアップデートに伴いプラグインのデフォルトブランチをmasterに変更 - rcmdnk’s blog